Libratone Support

Follow

App - Download compatibility issue (Android)

Some customers are currently experiencing issues downloading Libratone Android App from Play Store to their Android Smartphones.

Error message: 'Your device isn't compatible with this version'  

We are currently working to identify what is causing this problem and hope to have a solution soon.

We apologize for any inconvenience this might cause you, and thank you for your patience.

Android OS requirements

Please note that our latest Libratone Android App released October 12th is requiring Android 4.4 or newer. Previously Libratone Android App was also compatible with Android 4.2.

NOTE: LIBRATONE ANDROID APP IS NOT COMPATIBLE WITH ANDROID TABLETS.  

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments